This project is read-only.


Sep 26, 2012 at 10:56 AM


Maybe I'm just too stupid but if I'm calling Ask() an assign the result to a double value I see for example 128785000.0 in my VS watch window instead of 1.28785000 as expected:

       protected override int Start()
            double dAsk = this.Ask();
Any advice what I'm doing wrong here ?
Thanks, Stefan.
Sep 26, 2012 at 11:10 AM

I assume it is due Culture settings. MQL always use "." (dot) as separator for Double. Same used by .NET Framework in case US-En culture settings.

I some cultures for separator used "," (comma). TradePlatform.NET uses OS culture settings while parsing MQL results.

What culture settings you have? Nevertheless, this should be considered bug and will be fixed in next release. As a workaround please use En-Us culture settings.


Thank you.

Sep 26, 2012 at 12:17 PM


That's it. My culture settings are "de-DE". Changing this to "en-US" solved the problem:

Thread.CurrentThread.CurrentCulture = new CultureInfo("en-US");

Thanks a lot!

Btw.: this is an absolutely great project!


Regards, Stefan.

Sep 26, 2012 at 12:39 PM

Thank you for using TradePlatform.NET. Please review release and give 5 stars :)

Oct 29, 2012 at 11:52 AM

Fixed in TradePlatform.NET 2.0